RAID 1 в Netgear Stora


Tagged , , ,

Вчера была замечена особенность(читать косяк) у Netgear Stora. Вытащили 2й хард из него. Попользовались им некоторое время и решили обратно вернуть. Перед этим диск был зачищен в акронисе подчистую. Когда вставили, стора не захотела его добавлять в рэйд снова. В админке сторы был пункт Rebuild, но по его нажатию ничего не происходило.
Решением данной проблемы — вручную разметить жесткий диск. Если есть root доступ в сторе(хотя можно и на другом линуксовском компе), заходим по ssh и командуем

# /sbin/fdisk /dev/sdb

/dev/sdb — это и есть второй диск в сторе.
Далее нажимаем n — создать новую партицию. Выбираем весь объем жесткого диска. Создастся партиция sdb1.
Далее нажимаем t — выбрать тип партиции.
на приглашение Hex code набираем fd
Затем w — для записи изменений.
После того как изменения записались можно заходить снова в веб админку и снова жать Rebuild.
Начнется процесс восстановления рэйд массива и через некоторое время ( если 1 Tb, то приблизительно 2,5 часа ) 2й диск станет тоже «In RAID», а лампочка на сторе загорится зеленым. Все, данные снова успешно зеркалируются.

P.S. : Все действия я делал в боевом режиме, стора активно использовалась другими пользователями.

Мой блог находят по следующим фразам

Share:

2 комментария

RSS / trackback

Respond

  1. andrey

    on 27.03.2011 at 09:19

    после установки второго диска первый вообще перестал читаться(и после того как второй убрал).
    есть ли способ оживить первый?
    как с него вообще инфу взять???

  2. Человек_Разумный

    on 28.03.2011 at 00:47

    Ну то, что перестал работать первый, скорее всего просто совпадение. У меня все отлично работает, не раз уже переставлял. А насчет оживления, попробуй цепануть его к линухе, и вручную примаунтить. Так же можно прочекать его xfs_check или xfs_repair (man).